Welcome to MozTrap

MozTrap is a test case manager.


MozTrap requires Python 2.6 or 2.7 and MySQL 5.1+ with the InnoDB backend.

These steps assume that you have git, virtualenv, virtualenvwrapper, and a compilation toolchain available (with the Python and MySQL client development header files), and that you have a local MySQL server running which your shell user has permission to create databases in. See the full Installation documentation for details and troubleshooting.

  1. git clone --recursive git://github.com/mozilla/moztrap
  2. cd moztrap
  3. mkvirtualenv moztrap
  4. bin/install-reqs
  5. echo "CREATE DATABASE moztrap CHARACTER SET utf8" | mysql
  6. ./manage.py syncdb --migrate
  7. ./manage.py create_default_roles
  8. ./manage.py runserver
  9. Visit http://localhost:8000 in your browser.

Congratulations! If that all worked, you have a functioning instance of MozTrap for local testing, experimentation, and development.

Please read the Deployment documentation for important security and other considerations before deploying a public instance of MozTrap.

Indices and tables

Project Versions

Table Of Contents

Next topic


This Page